Announcement

Collapse
No announcement yet.

New Morimoto powerhouse ballasts not lighting CBI or CBB bulbs????

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New Morimoto powerhouse ballasts not lighting CBI or CBB bulbs????

    Hey guys, not sure if the correct forum but I am having issues trying to get my new d2s morimoto powerhouse ballasts igniting two different pairs of Bulbs, CBI and CBB.

    I was replacing some matsushita ballasts after the passenger side was not lighting everytime I turned the lights on, after a couple "on off" cycles it would light. it gets annoying so I bought come powerhouse.

    I made all the connections and nothing, rotated the igniter on the bulb portion numerous time and nothing, tried them on CBI and CBB bulbs and nothing. put the Matsushita back and presto, on both sets.

    any thoughts or known issues like this

  • #2
    You might have dud ballasts. I can't say myself, but I've heard they're pretty unreliable.

    2000 Toyota MR2 Spyder
    2017 Lexus CT200h F Sport

    Comment


    • #3
      I was thinking the same thing. But it was just weird that both would be duds.

      i already started my return to TRS and took advantage of the holiday sales and ordered some denso slims. Sucks that I have to pay a restocking fee and return shipping for unreliable ballasts.

      Comment


      • #4
        They made you pay restocking for defective ballasts?? They can't even restock them!

        2000 Toyota MR2 Spyder
        2017 Lexus CT200h F Sport

        Comment


        • #5
          Originally posted by Haloruler64 View Post
          They made you pay restocking for defective ballasts?? They can't even restock them!
          LOL, that makes sense! Maybe TRS will chime in and cut me some slack :fingers crossed:

          Comment


          • #6
            They don't come here unfortunately. You'd have to contact them.

            2000 Toyota MR2 Spyder
            2017 Lexus CT200h F Sport

            Comment


            • #7
              Originally posted by Haloruler64 View Post
              You might have dud ballasts. I can't say myself, but I've heard they're pretty unreliable.
              Had 2 die within 6 months. First one died, RMA'd it, then the second died maybe a week later. After that I just went back to regular ballasts.

              Also neither ignitor that came w/ them worked. Had to reuse my old ignitors from my XB55s.
              2013 Grand Caravan. LS460s + RX350s.

              Comment


              • #8
                Well got them returned and they didn't charge me the restocking fee as they stated earlier. got a full refund and I had already ordered Denso Slims

                Comment


                • #9
                  Good! Enjoy the Densos

                  2000 Toyota MR2 Spyder
                  2017 Lexus CT200h F Sport

                  Comment

                  Working...
                  X