Announcement

Collapse
No announcement yet.

2018 Ram 2500 Truck- H.I.D. won't consistently fire when truck is OFF, starts every time when truck is ON

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • 2018 Ram 2500 Truck- H.I.D. won't consistently fire when truck is OFF, starts every time when truck is ON

    Ok so here's my issue.

    Purchased HID kit from TheRetroFitSource. 2015+Mopar Kit (includes relay harness, 2 resistors for each side, 55w morimoto ballast and 5500k Osram CBI bulbs. Plus an anti flicker capacitor)

    After I finished installing I fired it up with everything double checked and connected. My truck has a feature (like many vehicles) where when you unlock your doors the headlights automatically come on. I hit the key fob and when my doors unlock only 1 of my lights starts to warm up like normal. the other light is making a loud electrical sound for about 10 seconds. during this time that light seems to not be getting enough power as it's flickering very dim. once the 10 seconds have passed then the sound goes away and the light that was very dim now starts to warm up like normal. sometimes that dim light won't even come on at all. it'll try to come on for 3 seconds after which it will just shut off and the other one will continue to warm up like normal.

    My truck is a heavy duty diesel so it has 2 batteries. one on each side. after experiencing this I then switch my harness around to the other battery. when I turn my lights on again (with the engine off) it does the same thing only this time it's the OTHER side that now won't turn on. to clarify- the side that comes ON each time is the side closest to the battery that my harness is connected to. the side that doesn't come ON is the opposite headlight where only a BALLAST wire goes to.

    I've had my ballast replaced and even my harness replaced. I've tried wiring up my kit without all the extras (resistors/capacitor) and with the extras and it still has the same affect. if the harness is connected to the driver side battery then the passenger seems to be lacking power. If I connect my harness to the passenger side battery then the driver side light seems to be lacking power.

    Here's the funny thing. If I turn my truck on and wait a few seconds, then I switch my lights on, both fire up immediately without any issue or any loud scratchy electrical sound. only your normal electric hum that's associated with a normal HID kit ballast.

    So I'm stumped....

    thanks for you help

    -Nick

  • #2
    I'd recommend trying some XenonDepot harnesses, they're individual harnesses, one per side. It might help. But I'm no expert on the insanity of MOPAR electrics.

    2000 Toyota MR2 Spyder
    2017 Lexus CT200h F Sport

    Comment


    • #3
      i had some slightly similar issues with my eclipse a while back-- turned out the harness had started corroding on the input leads, and updating the harness corrected the issue
      The time you enjoy wasting, is not wasted time

      Comment


      • #4
        Iíve had something somewhat similar happen on my 2015 Duramax. Iíve replaced everything (some things a couple of times). The latest fix was to replace both relay harness relays with GM relays. Pm me and I can get you a part number if you want to try it.


        Sent from my iPad using Tapatalk

        Comment


        • #5
          Originally posted by Haloruler64 View Post
          I'd recommend trying some XenonDepot harnesses, they're individual harnesses, one per side. It might help. But I'm no expert on the insanity of MOPAR electrics.
          Do you know what type of connections the Xenon Depot Harness has? I'm on their web page now, and I can't tell if this will plug into the Morimoto AMP to D2S XB35 ballasts or not.

          Comment


          • #6
            The inputs and outputs are all 9006. They're meant for PNP setups where you use the bulbs built in adapter, since all XD bulbs come with adapters built in (eg H7 to 9006). You can just get adapter separately though.

            2000 Toyota MR2 Spyder
            2017 Lexus CT200h F Sport

            Comment

            Working...
            X