Announcement

Collapse
No announcement yet.

HID Fog Lights keep FLICKING...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • HID Fog Lights keep FLICKING...

    WTF. I'm so irate about this. Finally fix the yellow lenses problem and now I put the bulbs in and they just keep flicking ever so slightly. WTF is going on? Do I just need to stop using HID and try regular Halogen?

  • #2
    What components are you using? Are you using a relay harness? Are you sure the flickering isn't the housing vibrating?

    Originally posted by cthunder
    The more you mod your car the moodier it gets.
    Avalon Dual Lens | Rogue LED | Mori 3800K | Mori 3Five | H11 PnP LED

    Comment


    • #3
      Originally posted by ATMJDM01 View Post
      Do I just need to stop using HID and try regular Halogen?
      It's a sign from God.... yes! lol

      Comment


      • #4
        I got the kit online and it's been PERFECT since. Well had to change the lenses to yellow so I can get that output. well the 3k bulbs were flicking so I go to install the 4300k and they flicker. It's not the vibration because they do it when the engine if off too..

        How would I go back to halogen?

        Comment


        • #5
          When you say online, you mean ebay or DDM? Guessing you need a TheRetrofitSource harness

          Hers-Sloped TL's, ZKW-R lenses, 85122+, E55-R, fiberglass buckets, Blazer fogs with 3K
          Mine- Morimoto Mini H1's, e55 shrouds, Blazer fogs with 3000K
          Zuma 125 Mini H1, Gatling Gun 2.0, 90mm & 60mm Amber XBLED halos
          https://www.facebook.com/pages/RetroFix

          Comment


          • #6
            How do I remove the HID Ballasts and make it regular halogens bulbs again?

            Comment


            • #7
              Is it a sign. Yes lol. But are you using a harness?
              AAAAAAAAAAA

              Comment


              • #8
                Ride the bus.

                Comment


                • #9
                  Attached them back to the halogen and it looks better and no more flicking. Guess it was bad ballasts or something. Thx guys.

                  Comment


                  • #10
                    Did you had a harness though?
                    AAAAAAAAAAA

                    Comment


                    • #11
                      I noticed today my pass side flickers on the durango. This is with a relay harness in place..

                      Comment


                      • #12
                        I'm using all TRS components. My passenger side low flickers for about 3 seconds and stabilizes. Other than that its fine. It isn't a continuous flicker. So I'm not too worried about it.

                        2000 Honda Accord SE -​Ruby Red Pearl
                        Morimoto MH1 5.0 5k 35W
                        Garnet-MR Thread

                        Comment


                        • #13
                          My driver one flashes here and there. Kind of weird because I've checked connections
                          AAAAAAAAAAA

                          Comment


                          • #14
                            I notice that mine flicker (they just dim a bit) when I hit a big bump. The grounds are all good and I'm using a morimoto harness. I know for sure that it isn't a problem with my electrical system or anything like that. As long as they keep working I guess it isn't that big of a deal.



                            99 Dodge Durango SLT SelecTrac (NV242) 4WD 5.2L Magnum V8 Build Thread
                            FX-R Retrofit - Picture Thread

                            2014 Dodge Charger R/T Awd

                            Comment


                            • #15
                              Yeah when I drive I don't see it on the road. Just against things in close distance
                              AAAAAAAAAAA

                              Comment

                              Working...
                              X