Announcement

Collapse
No announcement yet.

Intermittent flickering, even after replacing everything.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Intermittent flickering, even after replacing everything.

    I have a 2009 Acura TSX, factory HID's. Driver side headlight started flickering intermittently after I bought the car and I figured there was something wrong with the factory equipment because the car was in a wreck on that side. I replaced the factory HID equipment with a Morimoto kit from Retrofit Source because it was cheaper and probably better than the factory stuff. Light still flickered occasionally. My next thought was there was something wrong with the factory harness, so I built a harness kit with dual relays. Still flickered. Figured maybe my harness sucked so bought one from Retrofit Source, wired it to switch on/off from the passenger side to eliminate everything on the driver side. Still flickers. Replaced the bulb, igniter and swapped the ballast side to side. Still flickers. At this point I have no idea what else it could be. I've replaced or swapped everything. Could it be something wrong with the headlight housing that is causing it? It flickers whether the car is running or off, moving or sitting still. Please help.

    Edit: I've been dealing with this problem so long, I remembered incorrectly about the factory equipment. The factory driver side would shut off after first turning them on. I would have to shut them off and back on, maybe I few times, to get the headlight to stay lit. That's why I replaced them and thought the driver side was bad.
    Last edited by BDaniel05; November 2nd, 2019, 09:54 AM.

  • #2
    Is it possible that some sort of air leak in the headlight housing could cause this?

    Comment


    • #3
      When you swapped components (left for right), did the flickering ever move sides or momentarily remedy itself?
      Jul 2012 ROTM (3-way quad headlight) ; Sep 2015 ROTM (custom muli-lens 7" fogs)

      3-way quad wiring; foreground limiter; squirrel finder;

      Comment


      • #4
        If it blinks, at least when the lights are on, you need a transistor / capacitor. I have it located at the exit of the card, before the relay. Without that, when changing from low lights to high lights, all the xenon equipment was turned off. That worked well.

        Comment


        • #5
          Originally posted by satrya View Post
          When you swapped components (left for right), did the flickering ever move sides or momentarily remedy itself?
          No. It stayed on the driver side. The problem was always intermittent, though. However, it's gotten to the point where it's all the time now.

          Comment


          • #6
            Originally posted by Tractor-rojo View Post
            If it blinks, at least when the lights are on, you need a transistor / capacitor. I have it located at the exit of the card, before the relay. Without that, when changing from low lights to high lights, all the xenon equipment was turned off. That worked well.
            I didn't think it could be that because both passenger and driver are switched on with the passenger side stock headlight harness, but only the driver side flickers. Plus, I was also under the impression that was only a problem for certain cars that didn't have factory HIDs. The TSX has factory HIDs.

            Comment

            Working...
            X