Announcement

Collapse
No announcement yet.

SOLVED: AFS trouble after swapping projectors Prado 150

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • SOLVED: AFS trouble after swapping projectors Prado 150

    Hi guys.

    Back in January I decided to swap out my AFS non Bixenon projectors in my 2013 Toyota Prado (Landcruiser) 150 with RX350 Afs projectors.

    My old projectors was identical to Rx350, but only with single xenon and fresnel lens. And yes. It was AFS.

    Swapped them out, glue back on the lens and then the nightmare starts

    I got blinking AFS off light in the dash right away. That indicates a malfunction with the afs system.

    What happens with the motor when starting up the car is that it tries to move to the middle of the car (when the motor canít go any further because of the shroud). It stays there and try to move, but stalling over and over. Finally it stops and the lights goes in a kind of emergency mode and the AFS off lights come on.

    If if I manually force the projectors out. To turn like they should with afs. Left headlamp to the left. Right to the right. They adjust fine to the middle. And then tries to go further than the ďnormalĒ position.


    I have have now opened up the lights to figure this out. We swapped AFS motors to new one that works. But the excact same thing happen. Iím almost loose my mind now!! What to do?

    The motor cannot be mounted wrong because of the shape of the motors gear and the projector part.

    The Toyota dealer have tried with diagnose. But no luck.

    It only says malfunction with afs left and right motor. And the DTC cannot be deleted.


    The car is now without headlights. And the headlights is stored without the lens to find out the solution.

    I really hope someone here can help me. Itís a shame to see the damn AFS off light in the dash. And I donít think the car will go thru the inspection here in Norway!

    I HAAAATE AFS RIGHT NOW!!!

    Thanks and good night people!
    Last edited by LasseTheDude; June 9th, 2018, 05:16 PM.
    Skoda Superb 4x4 170 DSG TDI 2014

    VW Touran 177 DSG TDI 2014


  • #2
    The 2013 Lexus GX460 we have in the states uses a side mount projector, does the Prado use a side mount? The motors are mounted correctly and actually try to work, right?

    Comment


    • #3
      Is it a calibration issue? I know that the headlight level control on some cars doesn't have any feedback, 0 is whatever the head light level is when you plug things in. Is it possible that the thing is being set at a zero point that's not in the correct position? Is there any position feedback to the control module?
      2000 Celica GTS 'slowest gts evar'
      1998 Mazda 626 FS-DE/CD4E 'mom-mobile'

      Comment


      • #4
        Iíve only ever seen AFS issues arise when the motor either canít move or isnít responding. Iíve never seen a calibration issue on one.

        Comment


        • #5
          Here is the solution!

          It's insane... The plastic bracket on the bottom of the projector is only a few degress from center (offset) on the left one (RX350 OEM bracket) and the right one with A stamped on is my OEM from the Toyota! Swapped brackes and now it works perfect! Pretty sick. Only a few millimeters and all the trouble.

          Skoda Superb 4x4 170 DSG TDI 2014

          VW Touran 177 DSG TDI 2014

          Comment


          • #6
            Nice find and fix.
            2000 Celica GTS 'slowest gts evar'
            1998 Mazda 626 FS-DE/CD4E 'mom-mobile'

            Comment


            • #7
              WOW no wonder you missed that. Thatís hardly a difference. I know I wouldnít notice that. Nice work.

              Comment

              Working...
              X