Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Signs of a bad ballast?

  1. #1
    Senior Member HID Learner
    Join Date
    Jun 2005
    Location
    Illinois
    Posts
    171

    Signs of a bad ballast?

    I think I need a new ballast but just wanted to know if these are signs of it. I would check it but I have to off the bumper, grille, and lights and its freezing. So I'm going to do that once I get a new one.

    A couple weeks ago it wasn't working, turned it off and on and it worked.

    Yesterday it worked. Driving back home it didn't work. Came home, turned them off and on and it worked.

    Today, doesn't work at all. The bulb just flickers on for a second and turns off.

    I'm able to get to the bulb and the connector and thats it. I changed bulbs but same problem.

    I checked the connector and its kind of black and burnt on the inside of one corner. I'm assuming its the ballast/connector and not something major in the electrical system.

  2. #2
    Senior Member LORD XENON gearbox's Avatar
    Join Date
    Sep 2006
    Location
    NV
    Posts
    17,124
    classic signs of a waterdamaged ballast. bulbs almost never go bad, even after 5-6 yrs they will still come on, altho the color will be super blue or pink with not alot of light. you could try taking it off and opening it up to see where the water got in. sometimes you can clean the corrosion off the board and it will work again. but sometimes not.

  3. #3
    Senior Member HID Guru
    Join Date
    Dec 2006
    Location
    Greensburg, Pa (20 miles from Pittsburgh)
    Posts
    903
    Try to check the ground... If thats fine maybe a power wire or somthing?!?!
    "Get higher quality and be happy, rather than go cheaper and be disapointed and do it again! Its actually cheaper in the long run!"

  4. #4
    Senior Member HID Recruit
    Join Date
    Feb 2007
    Location
    Montreal, Canada
    Posts
    216
    wow how ironic brightness i tooo have a 06 altima and have an ls 430 retro that I did.....just tonight my passenger side bulb flickered before turning on... howwever im not using a relay so its possible its that... but it never happened before so im wondering

  5. #5
    Senior Member HID Learner
    Join Date
    Jun 2005
    Location
    Illinois
    Posts
    171
    Quote Originally Posted by Julian
    wow how ironic brightness i tooo have a 06 altima and have an ls 430 retro that I did.....just tonight my passenger side bulb flickered before turning on... howwever im not using a relay so its possible its that... but it never happened before so im wondering
    Ironic indeed... its my passenger side as well. Must be some Altima bug going around. LOL

    I fixed mine today though... got a Hella ballast locally around here and everything works fine now.

  6. #6
    Senior Member HID Recruit
    Join Date
    Feb 2007
    Location
    Montreal, Canada
    Posts
    216
    well i just came back from my the gym and as i was going when i fired them up nothing happened everything was normal...even in mad raining conditions its working fine now....i dont understand lol

  7. #7
    Senior Member HID Recruit
    Join Date
    Feb 2007
    Location
    Montreal, Canada
    Posts
    216
    question for you brightness.....where have you mounted your ballast on either side i had a heck of a time trying to fit my bosch ballast and they ignitors in there.....man i ended up using the ziplock plastic bag method for the time being.....if those last then good....if not ill buy a set of matsushitas but then how in the hell would u mount them in our cars? nsorry to go off topic guys

  8. #8
    Senior Member HID Learner
    Join Date
    Jun 2005
    Location
    Illinois
    Posts
    171
    Quote Originally Posted by Julian
    question for you brightness.....where have you mounted your ballast on either side i had a heck of a time trying to fit my bosch ballast and they ignitors in there.....man i ended up using the ziplock plastic bag method for the time being.....if those last then good....if not ill buy a set of matsushitas but then how in the hell would u mount them in our cars? nsorry to go off topic guys
    I have the Hella ballast and I was able to get these ballast holders that you slide the ballast in and it holds it in place.

    On the passenger we have the window fluid tank. To the right is the box for some fuses I believe. In between them there is a space and some metal. I screwed that ballast holder to some kind of unnecessary metal of the car and snapped in the ballast. It is basically between the fluid pipe and the fuse box and above the fluid tank... might sound confusing but once you take off the headlight and look in there you should be able to figure it out.

    I don't remember what I did with the driver side... I know I did something similar but I don't remember. I must have done something good as I can't even see the ballast.

  9. #9
    Senior Member HID Nut burley's Avatar
    Join Date
    Sep 2007
    Location
    Dubuque, Iowa, United States
    Posts
    553
    Im must be a complete moron, because today marks the second time I've fired up my ballasts w/out bulbs. I've also had a bulb come out of the plug while it was on. Cant be good.

    My question is, will the ballast ever become dimmer due to failure or will it just stop working all together/flicker when starting.

    thanks

  10. #10
    Senior Member LORD XENON gearbox's Avatar
    Join Date
    Sep 2006
    Location
    NV
    Posts
    17,124
    usually they just dont have the power to ignite the gas in the bulb. but if it can, and then is unable to maintain stable output, you will see the bulb flickering. if it stays a solid brightness, youre fine

Similar Threads

  1. PnP HID kit not lighting up street signs
    By vw guy in forum General Discussion
    Replies: 21
    Last Post: November 3rd, 2009, 11:36 PM
  2. How do projectors illuminate road signs?
    By ncstl77 in forum General Discussion
    Replies: 5
    Last Post: February 9th, 2009, 07:55 PM
  3. Signs of a dying bulb?
    By BLacK FirE in forum General Discussion
    Replies: 3
    Last Post: April 8th, 2007, 12:17 AM
  4. The glare helps me light up overpass signs
    By gtpboy in forum Projector Retrofits
    Replies: 9
    Last Post: November 6th, 2006, 03:54 PM
  5. LED rims, for signs/ messages, VIDEO!
    By magyver in forum LEDs
    Replies: 13
    Last Post: May 9th, 2006, 02:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •